Mobile Devices Compatible with Bizzon

Bizzon works on most smartphones and tablets running:

  • Android 5.0 or higher 
  • iOS 8.0 or higher 

The mobile device running Bizzon must be equipped with Bluetooth, since it is necessary for connection with the card reader.

We currently do not support: 

  • Blackberry devices
  • Laptop or desktop computers except under test conditions
Have more questions? Submit a request

Comments

Powered by Zendesk